Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

auto blank row after press enter in a cell

when I press 'Enter' when editing content in a cell, it will automatically add a new blank row on the bottom which is very annoying, how do I disable this feature?
Also, when I finishing editing a cell, the next cell in the same field will be automatically chosen to be in selected mode( have to press esc to escape or users might have to press enter all the way up to last record if they don't know the use of escape key),how can I disable it? thanks


  • To stop the new rows at the bottom, set the NewRowCount property to 0. To adjust what edit mode a cell goes into when it gets focus, use the CellEditMode property.
  • @KevinFournier
    I also have another issue

    When I click on the hyperlink cell(the first field), the third field (the only field thats editable in the table)is somehow "selected", could you figure it out?
    also, it is possible to increase the font size( bigger cell size for better display)?
  • My guess is that you set the CellProtection of columns 1 and 2 to Full, so when the table gets focus (which happens when you click the hyperlink), the focus goes straight to column 3.

    DataColumn and DataRow are used to set the sizes of columns and rows. CellFont is used to change the font.
Sign In or Register to comment.