Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

SRP Editor License Issue running SRP Editor

I have installed SRP Editor in an Open Insight 7.3 system . The editor starts and runs correctly in the SYSPROG app however when signed into any other app the SRP Editor gets continual licensing errors (see attached). The only difference between the two is the application selected (It's the same shortcut). There is no other SRP controls installed other than the editor. In the about screen for SRP Editor, the versions are the same and the license file is the same. The same error occurred under version 3.1.2. This error did not occur when running 3.01 I have tried this in multiple distinct 7.3 installations and it occurs in every one.

Please help to identify and resolve.



  • edited August 2020
    The controls look for an .SRPLIC file in a specific order. The working directory, the oinsight.exe directory, System32, and anything in the PATH environment variable. Not knowing your actual shortcut parameters, OI directory structure, or whether or not some code is changing the working directory, I can't really pinpoint the issue. I can tell you that the controls don't really care what OI app you are in. They just look in the above directories, whatever they might be.
  • I'm using the exact same shortcut to sign into Open Insight. The only difference is the application selected from the signin window. Is there something the application that would change the search locations ?
  • Kevin, when I look at the SRP Editor about and the active X control view under SYSPROG and the child app they both point to the same license file. I don't think it is an issue with finding the file but rather something in the logic that is not processing the license correctly (or it's getting cleared after it's read) when dealing with a child app. just MHO....
  • Is the UTF8 flag set differently for ESSEX302?
  • I think I know you're problem. I think you have copies of SRP_EDITOR entities in the ESSEX302 app that are outdated and overriding the new SRP_EDITOR. You need to remove any SRP_EDITOR entity that is in any app other than SYSPROG.
  • You were close. It is tied to to UTF 8 flag being set. I created a brand new app and the SRP editor starts with no errors, but when I check the UTF 8 box and start the SRP editor, I get the license error. I went back to the original app and verified that the behavior is the same (UTF 8 unchecked - good, UTF8 checked - bad) . We need to keep UTF 8 set due to having Chinese customers that use Simplified Chinese in their customer information. What's the next step ?
  • ps. I also tried this in brand new 9.4 environment and get the same issue in the SYSPROG app (UTF 8 unchecked - good, UTF8 checked - bad).
  • I'm not able to recreate the issue on this end using just the UTF8 flag. Did you check for duplicate SRP_EDITOR entities in the SYSREPOSWINEXES table?
  • Yep. None found. I can recreate this issue in a bare 9.4 installation. This environment has nothing it in other than SYSPROG and EXAMPLES as provided by Revelation.
  • Yeap, I can replicate this. We also have a UTF8 application that inherits SYSPROG. Just unticking the UTF8 flag in Application Properties will prevent the evaluation messages appearing. Even in SYSPROG itself, in UTF8 mode evaluation messages are produced when opening SRP Editor. It seems that the licencing for SRP Editor
    (and Table Search) doesn't like being in UTF8 mode.
  • Great!, that's fixed it. Good work Kevin :)
Sign In or Register to comment.