Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

OESocketServer. jar error

edited February 25 in OpenInsight
Has anyone come across this before? This is the first time I have had that fail on over 30+ client installs.



Background:
Windows Server 2016. User is Admin
That Jar file is deployed in literally dozens upon dozens of sites for us so I know there is no corruption there.
Client doesnt seem to use Java for anything else so updated JRE to latest Adopt OpenJDK (but message was the same with a old Oracle 8 JRE)
Revelation licence is current (had some issues with that in the past)
Had client's IT check A/V. They indicate they have fully excluded the entire directory the JAR resides in.
Event Manager shows no obvious error.

I am sure it must be a permission or something on the server but it is super hard trying to convince a 3PV of that.....

Comments

  • Are you sure the OEngineServer isn't already running as a Windows service?
  • ;-)

    Yes. This was a new install (on an client's exsiting server) for us so no previous OI install. The reason I am running in debug mode was because the service refused to start.

    I get that it is a very similar message but all other instances Ive had of that looked more like this:


    I double checked anyway. Definately no OEGCI or OENGINE or OPENINSIGHTS process anywhere to be seen!

  • edited February 25
    And you are certain the port is open (or is this where working with the 3PV is hard)?
  • Not 100% Don. I had tried a few different ports but I will pose the question.
  • Jared might have some ideas but I've gone ahead and posted in the Revelation forum as well for good measure.
  • You are a legend :)
    You definately dont pay yourself enough... especially when your work day is about to include tomorrow ;-)
  • Question has been posed. They are in a time zone a couple of hours ahead of us so they wont reply till tomorrow.

  • Here's the response I got from Revelation:
    So, immediately after startup it tries to shut down? My first guest has to do with some eserver.cfg settings (of course) - in particular, the error is complaining about the statsClientMonitor, maybe the settings for statistics generation are incomplete? Please look at the eserver.cfg for the Statistics_Output, Statistics_Directory, Statistics_ID, Statistics_Days, and Statistics_Input values - are the _Input and _Days values specified as numbers (no trailing spaces)? Is the _Output value a URL and port number (on my system, it's localhost\:18090)? Does the _Directory exist? Is the _ID non-null?

    Let me know what you think.
  • When trying to run as a service it fails to even start. Windows Service Manager throws an error.
    When trying direct from the CLI I get the response posted above. Based on those messages it still looks like it didnt actually start?

    I will say there were originally no Stats settings in the Eserver.cfg. However, like I said, that has never cause issues before. Regardless, I happily added some settings (the defaults I found in a Revelation document) and tried again. Same result.

    Here is my standard eserver.cfg

    //Listener Commands Procedure_=JD3_LISTENER Procedure_1=REVCMD_LISTENER //Password for OI UI EControlPassword=mdgBAJSK7sRBUHPOdFwZ8p7woj98W6qR //Startup and Shutdown Flags StartupFlags=66 //Use current engine if possible else new. Hide engine UI. ShutdownFlags=1 //Engine parameters MaxConnections=0 //Number of connections to engine MaxEngines=5 //Number of engines allowed MaxUpTime=0 //Max time in minutes allowed active in memory MaxRunTime=5 //Max time in minutes allowed run a request before 'hung' and terminated IdleTimeout=10 //Time in minutes can be idle IdleCheck=60 //Time in seconds between checks for idle and uptime/runtime //Ports PortNumber=8088 WebServerPortNumber=8089 //Stats Statistics_Directory=stats Statistics_Output=localhost\:8090 Statistics_Input=8090 Statistics_Days=14 Statistics_ID=MAIN

  • 3PV confirms ports are open and nothing blocking either of the ports we tried.



  • Will - Thanks. I've responded back to Revelation with both answers.
  • Much appreciated Don. Hope you have a good weekend :)
  • Will - Can you email me the exact copy of eserver.cfg you are using on this server. Also, please get the full version of the Java library being used and include that in the email or post here.
  • All sorted. Appreciate the assisstance Don (and Revelation!)
  • For those monitoring this thread or who come across it in the future, the issue came down to the insertion of comments in the eserver.cfg file. Whodathunk that would cause problems, but they did.
  • Don is just being polite. :)

    It wasn't the comments, it was the way they were used at line-end instead of own-line.

    As much as I said the config was the same as was used elsewhere (the settings indeed were), the comments were reletively new and undeployed....

    My bad.
Sign In or Register to comment.