Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

How do we get this?

I would like to utilise this, not sure if we have it already with the full SRP suite.
Please advise



  • Colin,

    This is a good question and one we get asked frequently by customers who have the SRP Control Pro package. While the SRP Application Launcher utility (note the term "utility" versus "control") does utilize an ActiveX control, the commercial product itself is not an ActiveX control at its core. It's a separate .EXE tool. The ActiveX control that comes with it is optional. Technically speaking, you do have the control already. It can be download for free separately but it is also built into the SRP Controls Pro single OCX file. By itself it doesn't do anything. Its value comes with the use of the EXE launcher.

    I confirmed that CSSP does not have a license for the SRP Application Launcher utility. Please contact me privately if you wish to acquire a license for this.
  • I have downloaded the install and copied the files to by app folder, so that I can test the concept.
    I set the parameters and renamed the EXE.
    It displays the nag screen, but does not launch the OI application.

    I note that it creates a VBS file, which if I run this then it launches the OI application as expected.
    Any ideas please?
  • Colin,

    First things first. Whatever you name the EXE file to you also must name the INI file to match. That's how you can have multiple EXE launchers in the same OpenInsight folder and each one doing something unique. For instance, we like to have a launcher for developers and another one for regular users. Perhaps you have inherited applications and you want each one to have its own launcher.

    I have no knowledge of this VBS file. What is the full name of this file?
  • Don

    My error, I renamed the SRP exe as RIPACLaunch.EXE, as I already had a RIPAC.EXE so thought I would just make up a name. It just so happened to be the same as a previous RIPACLaunch.vbs file, just a fluke really.
    I wrongly assumed that the SRP tool created the VBS file and used that.
    Ignore this point.

    I have renamed the INI file to the same as the EXE file.
    Still does not launch for me.
    INI file contents look fine to me, and I have tried different dev and hide settings.

    Also noted that the nag screen refers to version 1.1.1, but the EXe properties has version 1.2.3


  • Colin,

    The nag screen is indeed mismatched, but that shouldn't be a concern.

    I disabled my own license file to test this out. Like you, I got the nag screen but it did launch OpenInsight. So, I'm beginning to suspect that INI file has a problem. Would you mind posting the content in the thread or at least sending it to my email address for inspection?

    Also, what is the name of your EXE at the moment?
  • To all who are monitoring this discussion, after quite a bit of going back and forth and additional testing, we discovered that the nag message itself had something to do with the SRP Application Launcher failing to execute further. Once Colin was licensed for the product, it worked as advertised. We are still trying to understand why it didn't work in evaluation mode but the good news is that the licensed version is functional.
Sign In or Register to comment.