Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

Error on Boot.

Anyone have an idea on this? I see it everytime I start the EXE

That is the path to a RDK update that was supposed to install a couple of dictionaries (one of many actually. None of the others seem to have caused an issue). Something has obviously gone wrong.

I can get rid of the message by making sure the RDK still exists there.
I dont know what residual pointer it has because I can not see anything attached from that location in the DB Manager.

Of course it is on a Friday and on a client's site so any help would be appreciated!


  • OK. If I run the RDK again I get an DB entry I do not expect.

    (The table should exist under the APPDATA\DATA entry)
    If I unattach and resave the DB I still cannot start without the error unless the RDK remains in place.

    Clearly some remanants I cant find. I cannot se the Purchase_5 table anywhere!

    If I try to manually add the table as new I get a DICT already exists message :

    Any ideas how to get rid of that DICT pointer?

  • From the system monitor try:

    run detach_table "DICT.PURCHASE_5" run detach_table "!PURCHASE_5" run detach_table "PURCHASE_5"

    This would detach the dictionary, index (id indexed) and data portion of the table. It sounds like the DICT got attached in the DBT file from a location other than where the data portion of the table resides.

    Once those commands have been run try and attach the table "PURCHASE_5" from the APPDATA\DATA location where it's supposed to be. It should attach all 3 parts of the table from that location.

    If that works be sure to go into the database manager and save the list of attached tables.

    If that does not work you may have a lingering entry in the DBT file pointing the DICT to the wrong location. If your OI application name is OPTO then you should have a file named OPTO.DBT in your root openinsight directory. This file contains the list of files that OpenInsight attaches at startup. It's possible to edit this file by hand with the right editor BUT my recommendation would be to restore the OPTO.DBT file from yesterday's backup, start up the app, and attached the newly created tables from the correct locations.
  • @JaredBratu,

    Sorry for the delay.

    Thanks for the respnse and commands. I didnt get to use them as I had already gone to restore a full backup I had taken prior to starting anything. I had already tried just replacing the DBT already but that hadn't worked and I was under time pressure.

    I think you are right in that they were attached in different locations. In my various attempts I saw both dictonary loaded without a data file (could open in table bulder) and a data file where there was no dictionary. I could fix neither with the standard DB Manager tools.

    It shoud be noted that once I restored from backup I followed th EXACT same steps again (as I had run those upgrade files many times before) and had absolutely no issues the second time around!!!!

    I will store the detach_table option in the memory banks for future troubleshooting. How does that differ from a 'Remove Table' from the DB Manager?

    Thanks again Jared!

  • The Remove Table menu in the Database Manager is the equivalent of this Detach_Table command:
    run detach_table "PURCHASE_5"
    Normally this is sufficient, as this will also detach the dictionary and index table at the same time. However, if the data table is already detached but the dictionary or index table are still attached, Remove Table won't work. Thus, running the Detach_Table against each table by their specific name guarantees they will all get detached.
  • @DonBakke,

    I think you are 100% spot on why my Remove Table was not working. Like I told @JaredBratu, that little nugget is going into the toolkit!

    Appreciate the help from both :)
Sign In or Register to comment.