Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

SRP Editor 3.3.8 - Line number not showing


I have installed the new version SRP Editor 3.3.8. (I am using Open Insight 9.4 , and the old version was SRP Editor 3.0.3)
Issue I have, is when restart open insight, the line number, do not show. (This is only happen when I updated SRP Editor 3.3.8)

I can manual set this, "Show Line Numbers", then restart OI, line number missing

Your thoughts?

Geoffrey Fong


  • I suspect you will get an answer tomorrow (which is Monday for us) by the lead engineer on the product when he reports to work, but I am curious what your version of SRPEditor.ocx is. Can you take a screen show of the Help > About window and also post that?
  • Right+Click on where the line numbers show and select 'Show Line numbers'
  • Thanks Barry, I know you can do that. Also there is an option in SRP Editor, that you can set.
    When you restart open insight, the line number are not showing. I am having this issue with SRP 3.3.8
    Please refer to first attachment on info

  • >>Also there is an option in SRP Editor, that you can set.
    Yes I know that, but, rightclick appears to be a sub option.
    I assume that if it is off in the options, you dont get the 'sub option'
  • I wonder if the big jump in versions caused the options to get out of sync. One thing you can try, though it will cause you to lose all your current options, is to open RegEdit and remove all the entries in the following folder: Computer\HKEY_CURRENT_USER\Software\SRP\SRPEditor. This will reset all options for the SRP Editor to their defaults.
  • Another thing I've seen after a major update is copies of SRP Editor entities in local applications. If, for example, you look in SYSOBJ and see $SRP_EDITOR_OPTION_DLG_EVENTS and $SRP_EDITOR_OPTION_DLG_EVENTS*MYAPP, then the MYAPP version (which is probably still at the older version) will override the updated version.
  • Hi Kevin,

    Thanks, I reset the Regedit. Still the same. "Line Number"


  • I've tried to recreate this to no avail. Try turning off line numbers in the Options (click OK or Apply) followed by a restart. Confirm that line numbers still don't appear. Then turn line numbers back on in the Options and restart again. See if it sticks?
  • Hi Mark :)
  • Hi Kevin,

    I have been testing again, FYI - Using Open Insight 9.4 and SRP Editor 3.3.8 - Local Disk.
    The line number works in SYSPROG.

    But in another account, it does not. Please refer to attachment on Step 1... Step 4 more info

    Your thoughts?

    Thanks and Kind Regards

  • The fact that it breaks outside of SYSPROG leads me back to the theory that you have old SRP_EDITOR entities in your system that are not at the SYSPROG level which are overriding the latest update. Check SYSOBJ and SYSREPOSWINEXES for any entities beginning with SRP_EDITOR that are not in SYSPROG and delete them.
  • To piggy back off of Kevin's suggestion, try your test on a different application other than SYSPROG and your primary application. For instance, if you still have the EXAMPLES application then test there. Most likely it will work.
Sign In or Register to comment.