Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

4 - OCX controls and 1-DLL file.

I need the *.ocx files for SRP editor and if the Table_Search function uses any ocx control as well. SRP editor is already installed but need the *.ocx files on the local drive/folder - SRPControls.ocx/SRPControls64.ocx/SRPEditor.ocx/SRPUtil.ocx and SRPUtilities.dll. Developer workstations were rebuilt, but the ocx controls were not installed nor activated. I am looking for the ocx and dll controls listed above. As well, we need the specific controls that match the rest of the development team, not sure of the version# but I was told there were created 02.16.23 and modified (I presume installed) on 02.17.23. TIA. Best,


  • thanks Kevin, are these the ones that are used @NCB? As apparently there is some versioning issues, so I was told to obtain the "version" post Feb5th event. TIA.
  • Another question, I was told SRP editor was already installed on my workstation, but it doesn't run, so noticed no *.ocx, was instructed to obtain the *.ocx and *.dll and just drop them in my \\revsoft\client\... folder and register the controls and it will work. Does that sound right? I can just copy them to the folder, in DOS "register" and then all s/b good? TIA.
  • Kevin - in original request, I requested SRPUtil.ocx, would you provide that one as well? Mahalo!
  • These are the latest builds. If you tell me what version numbers you want, I can get you what I can. Build dates are hard to run off of since Windows sometimes will change those files dates as they get moved around and copied. SRPUtil.ocx is deprecated, it was supplanted by SRPEditor.ocx.
  • Got it, thank you.
  • ok, as suspected, that wasn't the issue. I have attached what my SRP Editor looks like -- its not working and I suspect it needs to be installed, the same for the TABLE_SEARCH function. Can you look at the attach and tell what needs to happen in order to fix it. I think it has to be re-installed, only I have been told, cannot install SRP Editor onto the server and use our VM workstations, as apparently a specific version of the editor (or the dll) is already installed, if I try to install SRP editor, it disabled the editor for all other users. Any suggestions? Don B is aware of which client this is. TIA.
  • You have to register the SRPEditor.ocx on each machine that uses it using the regsvr32 command.
  • you mean like the attached? in an elevated DOS session, I went to the folder which contains the *.ocx files, ran the regsvr32 on all three *.ocx files separately, I received the dialogbox that registered was successful, bounce workstation and ran OI, SRP editor, still a no-show. any other suggestions? I am on a VM workstation that has client files on my local VM workstation that then attaches to production server via a desktop shortcut. TIA. Stacy
  • If you registered them on the VM workstations, then I can't really explain why OI can't load them. If you open REGEDIT and then search for SRPEDITOR.Button.1, does it find anything? If so, look in the nearby InprocServer32 folder and see the file path the OCX. Is that the one you registered?
  • edited March 14
    I actually think SRP editor has to be installed, as I do not think it was setup correctly when VM workstation was created. Not sure, but am going to send this issue to HelpDesk, as I have tried many things and none have worked, I cannot check the "InprocServer32" folder, as we are not allowed to map to the PROD server/drives, if not on c:\, I cannot access it. Am going to setup a TTicket with HelpDesk, gut feeling all along, has been to reinstall SRP editor onto the VM workstation. Attached is what my Editor form looks like. FYI, Best,
Sign In or Register to comment.