Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

Failure sending error

I have a customer who is receiving a failure sending message. Prior to this message they were receiving a detailed error message regarding smtp authorization for this account's mailbox, which they resolved. They are running SRP_Mail v3.01, OI 9.4, and Windows 10. I have checked that they have .NET 3.5 and 4.8 installed, and re-ran clientsetup and included RevDotNet (which should have already been installed). I can copy their OI folder over to my computer and email is sent without an error. I don't know how to troubleshoot this further as the message does not indicate what the issue might be. I believe I had posted about this before, however, is there a way to get a more descriptive error message so that I can pinpoint the issue?


  • It depends on why the message failed to send. If this message is coming from the destination server then we only get what we get. If the message is due to a failure at the client level (such as a missing dependency) then you should get a detailed error (or you ought to be able to get a detailed error). What is the exact error you are now seeing?
  • Hi Don. The message now is either "failure sending" or "send failure" but I can get the customer to confirm. Again we were getting a detailed smtp error message when the mailbox was not authorized, but once that was resolved, this is the message we get now. I suspect it is something with the client as I can successfully send using the same setup on my computer.
  • Try this version ( and see if it gives you a better error message.
  • Thanks Kevin. I will arrange with the customer to install and try this.
  • I was able to install the new dll and we reran the test and now get the following error, "Unable to read data from the transport connection: net_io_connectionclosed."
  • What port are you using?
  • If you're using 465, try using 587 instead.
  • We are using 587. Again, I can copy this system over to my computer and the email is successfully sent. Could it be that their firewall is blocking port 587? But then we were getting the smtp authorization error for the mailbox, so wouldn't that require communication via port 587?
  • Is the client system an older machine? For example, Windows Server 2008 RC2 doesn't support TLS 1.2, which most email servers require.
  • I believe it is Windows 10 but I will confirm with the user.
  • They uninstalled their anti-virus software and now they get the message below:

  • Here's version This one will also return a stack trace on the error. This will help us narrow down what's going on.
  • Thanks Kevin. I will arrange with the user to try this version and will post the message generated. It will probably be done on Tuesday as Monday is a holiday here as well.
  • The user has been out of the office so I was delayed in trying the last update to the DLL, however, it returned the same error as initially, "Unable to read data from the transport connection: net_io_connectionclosed". I verified that the DLL was v3.0.3.1.
  • Yes, I expected the same error. I was hoping to see the stack trace as well. This will tell me what module is failing so I can better isolate the error. Was there more info than just the message?
  • That was the complete message. I included a screenshot below:

    Do think they should uninstall the .NET Framework and re-install it?

  • Is there anything else I can suggest they try?
  • Do a full re-install of the OI Client setup and of SRP Mail. Just make sure we've cleaned everything up. Then run it. If it gets the net_io_connectionclosed error, disable the client's antivirus and try again. The fact that you got a different error when that was disabled has me curious.

    You may also want to open the Registry Editor and look in "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols" and see if TLS 1.2 is there and if it is enabled.

    Something is blocking the connection, which is why it's working on your machine and not theirs.
  • Try this latest build. It now programmatically forces TLS 1.2 instead of relying on the system. This worked for another one of clients having a similar issue.
  • Thanks Kevin, I will try this build. I did try uninstalling and re-installing the OI Client setup and SRP Mail but got the same message. There was no registry key on their system or mine either. I am still waiting for their IT person to disable the firewall and antivirus.
  • This last build worked! We successfully sent the test email after applying this update, with no errors. Thanks again for your help with this Kevin. Can I apply this to other installations of v3 or higher?
  • Absolutely. I'll be putting it up on our website shortly as an official release.
  • Great, thanks!
Sign In or Register to comment.