Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

SRP Controls download/install version

The srpcontrols download shows that the version is, but the version on the ocx that is installed is showing

As we are trying to isolate issues , can you confirm that the ocx that we are downloading/installing is actually *.6 and the ocx files info has not been 'updated'


  • @BarryStevens

    I have a downloaded history of the 4.2.x series Controls and I can verify that the registered Is showing as such, both via Windows properties and SRP_ACTIVEX_INFO

    Thats is for a Control grabbed via the forums.
    The latest Product download, that I am aware of, is so anything later than that is just an OCX from the forums?

    I also have a habit of unregistering (even though not really needed) and re-registering the Controls every time, even for the smallest dot releases...
  • If you hover on the official download link, it popups up

    Pretty hard to find forum released one amongst all the postings. I would be interested in a link to
  • Ahhh, so it does.

    Obviously newer versions of the Controls are available, though we know Kevin is looking into an issue with the latest. I take the forum release hotfixes as 'Beta' that only I play with (unless I know it fixes a particular issue I have from a 'release installer' version that has been deployed to site).

    If you really wanted that version specifically for some reason, Kevin posted it here (May 12th entry):
    Its only the x32 OCX though and it was quickly superseded in the same Forum Topic....
  • Thanks for catching this oversight. The download from the products page should now install as advertised. Thanks, Will, for providing the link as well. You guys are awesome.
  • @KevinFourner

    Are you sure the changes that were done in the 32bit ocx also went into the 64bit ocx, probably ribbon related somehow as the issue is a strange one.
    OI9 Version issue occurs, but not not now in
    OI10 issue occurs in and now also in

    The issue is this: OI9 and OI10
    A form loads data into an edittable, does a send_event WRITE then a send event READ and the edittable is now empty, tracked to the write event not writing the data.
    This happens when run from the ribbon menu.
    If run from the form designer and the ribbon is closed, then all works as should.

    Installing the ocx the issue is solved.

    Installing the ocx the issue is still there.

    Is any of this familiar to you?
  • ...in OI10 run from the form designer also has same issue with
  • Code tracing to find any issues that seemed out of place showed me the the SAVEWARN was not being set by the system when databound controls were updated. Not sure why the registration of the new srpcontrols had this affect.
    Anyway, I changed the code with some of my 'I would do it this way' and then it worked as expected.

    All I can think of is that we all know that OI10 has changed the way it does things and with very strict internal rules, so, maybe we ended up with a clash of events timing somewhere.

    Just thought I would bring you uptodate in case this might reveal something for you.

    If you need the before and after code, I will only send it to you via email and consider it private.
  • Can you test and let me know if the problem persists?
  • No, the problem still exists
  • This all testing using the OLD code.
    Running from the formdes now works, BUT ONLY if the MDI-ribbon has not been run.
    Running from the MDI does not work.
    I just noticed that the .ocx was not registered, so I will test again.

    But in the meantime there is another issue with this version.

  • same as reported before, issue still there
  • I appreciate your patience, Barry. Try This one should should behave a lot better. Also, starting with version or later, use the ribbon's MDISize property to position the MDICLIENT control. The documentation will explain why.
  • I can't explain the SAVEWARN and WRITE issue. My controls don't have access to that layer of OI. Your theory that OI 10 does things differently has merit. I'm always willing to troubleshoot, but I would need an RDK recreating the problem to isolate whether or not my controls are factor.
  • I am a big confused about these version numbers you are stating, as what I believe is the current version is
    Have I missed something with the 4.2.2 series?

    I will now install the and see if that fixes the major MDI issue , which was working OK in
  • fixes the ribbon issue.

  • 4.2.2 hasn't been released, so any 4.2.2.x I give you is a new beta build until I officially release. Big under-the-hood changes happened in 4.2.2.x, which I had to undo in Almost everything has been centered around making the Ribbon behave in OI 9 and OI 10, which behave very differently.
  • Ah, Ok thanks
  • I see that beta 4 is release, so I will, just out of curiosity test that non-working code I mentioned. I will let you know if it now works.
Sign In or Register to comment.