Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.


Not sure if I may be doing something wrong...

Setting up the engine server to test, configured for 1 server port 7777 and setup an init command which works and uses the other engine of the dev license.

When I send the follow command in OI..

TcpClientHandle = 0 If SRP_TcpClient(TcpClientHandle, "CONNECT","", 7777) then SRP_TcpClient(TcpClientHandle, "SEND_SES", "RUN TEST 123") SRP_TcpClient(TcpClientHandle, "CLOSE_SES") end

the SRP engine window dissapears, the OI engine closes but it stays in the task manager as a running process and the command doesnt run...

what have I done wrong?? (OI 9.4)


  • and these are the 3 debug files, no info in there that seemed useful tho
  • Aaron,

    Well, that code looks good to me. In fact, it looks nearly identical to production code I currently have running (even the IP and port are the same). The only difference, naturally, is the command I am sending via the SEND_SES service. I also quoted my port number, but I really do not think that is relevant.

    Can you confirm that the SRP Engine Server is not running? I know you said it disappeared, but that can happen while the system tray icon moves into the hidden icons panel. There should be a running process in the Task Manager (although it might be abbreviated as SRPENG~1).

    What does your TEST routine do?
  • In this test instance it didnt stay running, the two before that it remained in the task manager but windows dissapeared...

    test function is one line

    OSWrite Param To "nettest.txt"

    See video attached for a better idea...

  • Your video was very helpful. It eliminated about a dozen questions I might have asked but no longer need to do. However, this did not bring me any closer to a solution to your problem.

    I installed the exact same files I sent you and created a very similar test environment. The only significant difference was the name of the database and username that my INI config file is using. Everything worked as expected so your troubles perplex me.

    I take it you are testing an engine with more then enough user licenses. For what it is worth, here are my code samples:

    Subroutine Test_SRP_Engine_Server(Param1) Declare function SRP_TCPClient Declare subroutine SRP_TCPClient If Assigned(Param1) else Param1 = "" TcpClientHandle = 0 If SRP_TCPClient(TcpClientHandle, "CONNECT","", 7777) then SRP_TCPClient(TcpClientHandle, "SEND_SES", "RUN TEST " : Quote(Param1)) SRP_TCPClient(TcpClientHandle, "CLOSE_SES") end Return

    (Note, I am quoting Param1 so that I can safely pass in text with spaces. You don't need it for your simple test, but I wanted to throw that out there.)

    Subroutine Test(Param1) If Assigned(Param1) else Param1 = '' OSWrite Param1 to 'nettest.txt' Return

    When I run this, I get the following to appear in my OpenEngine:

    I also get the file to appear in my OI folder.
  • the dev environment is 2 user, so I have the engine count set to 1 in the config for the SRP server, would that make any difference?

    I will try your code now, and also try it in runtime to see if it makes a difference...
  • Honestly, I don't think it should make a difference. The fact that you launched the SRP Engine Server and that it spawned an engine ready to accept a connection is pretty much all the verification you need. Consider my comment "grasping at straws".
  • hmm, no matter what i do, dev or production, exact copy of your code sample, always crashes :-(
  • well there you go, it doesn't run under Windows 7 inside Parallels on my Mac, copied it across to my PC and works fine...how annoying, but good that problem solved, only down side is i now have to use a PC to do development on it.
  • Aaron,

    That is interesting. We have clients running an entire OI application (server and workstations) via Mac hardware and Parallels (or some other popular solution.) I cannot recall if they are using the SRP Engine Server. My guess is that Parallels does not support one of the libraries being used.

    On the one hand, I'm sorry that you can't have the full experience you wanted. On the other hand, I'm rather relieved you figured this out. Since you never mentioned anything about Parallels, I would never have thought to go down that path. Now I know to ask that question in the future. :)
  • Okay so back in the office today, brand new fresh install of Windows 7 Pro on laptop, copied across OI and ran the server, simple call using above test and it still closes and crashes the engine server, every time...

    It's getting a bit frustrating as to why as we need to get this out and running ASAP?!

    please, need help with why it is always crashing...have tried the following:

    - SRPEngineServer v1.3
    - OI 9.4 (plenty of user accounts) - use OESocketServer no problems

    - have run as my app as well as SYSPROG to test - same issue
    - tried using "", network IP as well as compute hostname - same issue
    - have tried with and without linear hash - same issue
    - have turned off firewalls, UAC, everything - same issue
    - works with calls via the directconnect control - works perfectly and returns results
    - have tried different ports - same issue
    - have tried one engine and 10 - same issue
    - have tried using XP - same issue
    - tried on OI 8.0.8 - same issue
    - tried on remote desktop Windows Server 2008 machine - same issue
  • Aaron,

    Your thoroughness is very much appreciated. At the moment I'm stumped as to why you are having troubles but we will pursue this with you.

    I hate to cast suspicion upon the file I sent you, but I am beginning to wonder if it was corrupted in some way before it reached you. I can try to resend it to you, but before I do that I would like you to try a slightly earlier build of the SRP Engine Server. I will send you the link via email. This is the release build prior to the one you currently have. Perhaps, just perhaps, it might work for you.

    If this doesn't work - especially if you continue to get the same crashing - I would like to recommend that we schedule an online troubleshooting session.
  • Tried the RC2 version you send through, unfortunately same result, may need to do an online session to show you and see if there is something I am doing wrong.
  • so...did some more investigation with a dummy tcp client to see what it was sending etc...

    seems the version of the SRP_TCPClient's "SEND_SES" function that I was using on the other machines (installed from the SRP_Editor setup.exe file) sends a header type of 0x03 and that crashes the engine server, whereas the version from the latest utilities (guessing it has been updated) sends an 0x04 header type and that works correctly...just confirming that this solves the issue on my other machines now.
  • yep, was an old SRPUTILITIES.dll from 02/15, replaced it with the one from the working machine and all ok now.

    /end frustration :D
  • Aaron,

    First, thanks for testing the other file I sent you. It was late Sunday for me when I did that and I had to leave my desk for the rest of the evening so I was unable to respond to you after you replied.

    Second, this is great news. Sincerely, I applaud your troubleshooting techniques.

    Third, once upon a time you reported this was working after you moved way from Parallels onto your PC. Were you not working with the same copy of OI? I am trying to figure out how the version of SRP_TCPClient would have changed on you.

    Finally, I'm sure you've done this, but remember to go back to the official 1.3 release.
  • same copy of OI, but upon copying I had to reinstall the editor to register the ocx's but on the working version i then installed the utilities on top of that, whereas i don't think i updated the utiliities on the non working ones, either way, works now :D
Sign In or Register to comment.