Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

Setup IIS with API


Is there a white paper for the best way to setup IIS with the API.

Thanks Anton


  • Have you reviewed the server preparation list from the online docs?
  • Hi Don

    It works if we use a single install with IIS(new install). Because we want to still use both version (old and API) at the same time (RUN_OECGI_REQUEST and HTTP_MCP) with two registry setting a two services and different ports until we have changed all function to API calls. Where we have a problem is that once both services are running both calls are going to the HTTP_MCP. We have created two virtual directories using OECGI3 for the old version and OECGI4 for the API calls. So somewhere we must miss a step.

    Thanks Anton
  • I see. What does your registry entry for OECGI3 look like? Is RUN_OECGI_REQUEST configured in that entry?
  • Hi Don

    OECGI3 Reg uses RUN_OECGI_REQUEST Port 8088
    OECGI4 Reg uses HTTP_MCP Port 8095

    Thanks Anton
  • In general, it appears you've done what is required. Are you sure your URLs are resolving themselves to point to OECGI3.exe and OECGI4.exe as needed? Are you using Rewrite Rules for the OECGI3.exe URLs?
  • Hi Don

    We are using the ReWrite Rules for the API (OECGI4.exe) only.
    Will check where where an how it is resolving ..

    Thanks Anton
  • Hi Don

    Have worked this week with an Web Developer to test the registry setting with sub keys.
    The Api call are working from the parent folder but not from the sub folder.

    What are the latest versions of OESocketServer.jar and Revjapi.dll and OECGI4 (v4.02)

    Could be the problem be with an older version of any this file.??

    Thanks Anton
  • When you say 'The Api call are working from the parent folder but not from the sub folder.' Do you mean the URL 'folder' or a Registry folder? For what it's worth OECGI (3 and 4) use sub-folders in the registry to determine which settings to apply based on the URL. Consider these 3 registry paths:

    OECGI settings in this path are the default settings if no URL match is found:

    OECGI settings in this path apply if the first segment of the URL begins with 'carsapi'. I.e. www.example.com/carsapi:

    Same as previous example but these settings are applied to www.example.com/trucksapi

    Because you are using OECGI3 and OECGI4 and each have their own default settings I don't think you are using sub-folders in the registry but if you are please let me know because it will impact what settings are used.

    Assuming you are not using registry sub-folders do you mean the URL path? I.e. does this function:

    While this URL does not function:

    If that is the case could you report back if you are adding the API to a dedicated site or an existing site as a virtual directory? ( See this link and the sections 'Dedicated API site Domain or Subdomain' and 'Adding an API to an Existing Site'. The rewrite rules are are slightly different for each and the placement of those rules is important (i.e. in the root directory verses the virtual directory). This could very well explain the issue you've reported with the rules working in the parent folder but not the sub-folder.
Sign In or Register to comment.