Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

64 bit OCX registration error

regsvr32.exe returns this error message. I am running command as administrator. I am using the 64bit c:\windows\system32\regsvr32

The module "SRPControls64.ocx" failed to load.

Make sure the binary is stored at the specified path or
debug it to check for problems with the binary of
dependent .DLL files

The specified module could not be found.

This is on a 2012 Windows servers. Is there a dependency I need to install on the server?



  • I suspect there is a dependency on 2012 missing. I'll have to locate a copy of 2012 and see if I can determine that. In the meantime, note that you actually do not need to use the version of regsvr32 in system32. Just use regsvr32 from the within the OCX's folder. That version will detect if the OCX is 64-bit and automatically run a 64-bit registration behind the scenes.
  • Kevin, I made an error on my post.
    I tried to register the ocx on a windows 2008 server. This returned the above error.
    I tried again on a 2012 server and it was successful.

    We do not need to support Windows 2008, so please disregard.
  • Ah, yes. While we try our best to support Win Server 2008 RC2, we've noticed that is a temperamental environment.
  • I'm getting the error as above but on my Windows 10 desktop! It doesn't seem to matter where I put the SRPControls64.ocx file (v4.1.2) or which version of regsvr32 I use. I'm running it at the Administrator Command Prompt. It seems like there is something missing in my Windows 10??
  • And this is Windows 10 Pro?
  • Yeap. Version 10.0.17134 Build 17134
  • It is probably missing needed dependencies, which is odd since Windows 10 Pro should have everything needed. You might need to use Dependency Walker to see if there are DLLs it needs that are unavailable on this machine.
  • Matt, if you right click on SRPControls64.ocx and open the file properties is the 'unblock' button visible? If so, please click it. Perhaps when you downloaded it the file came through as untrusted.
  • Thanks Jared - unfortunately it's not showing as blocked. Yes, I've been caught out by that before ;).
  • Thanks Kevin. I've successfully registered SRPcontrols64.ocx on another Win 10 machine so it does seem there's something not right with my workstation. I've run Dependency Walker on both machines - it shows errors even with a successful registration, however my log shows an additional error:
    Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.

    I'm not sure how to troubleshoot from here - any ideas?

    Cheers, M@
  • Yes, there are always errors, but that's usually at the lower level. The main thing you want to look at are the DLLs immediately beneath SRPControls64.ocx.

    That error is suggesting that our OCX uses a particular method that doesn't exist in the version of the DLL installed on that machine. So, the DLL is there, but the desired method is not. That usually indicates that an older version of the DLL replaced the more current one. I can't tell what DLL (if any) would be responsible from this screenshot alone.
  • Ah, thanks! Looks like I don't have a VCOMP120.DLL
  • That's the runtime for the version of C++ I used. Very odd that it wasn't already on the machine since it dates back to Visual Studio 2013. The only OS I've come across that usually is missing it is Server 2008.
  • @MattCrozier does this put you back in business? Do you need a copy of this or can you take care of that?
  • Yes, thanks Don. I've grabbed this from another machine and I've got SRPcontrols64.ocx registered now. Just want to figure out why I was missing it, and what else might be missing!

    Cheers, M@
Sign In or Register to comment.