Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

Cursor disappearing

I have a problem with the cursor arrow disappearing in the body of the SRP_Editor. This seems to only happen with a
Citrix desktop. I have tried everything I can think of to correct it but I am fresh out of ideas. The SRP editor seem to be the only application I am seeing it in. If I click on something say in a stored procedure I do get the vertical bar indicating position but try to move the cursor to click on something else and the cursor disappears. This only happens in the body. The cursor shows up okay when moving around the title bar area or favorites.

Any help would be appreciated.


  • First, I moved this discussion into the SRP Editor category from out of the SRP Editor Control category.

    Second, I've seen what you've described but I see it with other apps. Just curious, what happens if you try this with the Editor++? I'm checking to see if there is a connection to the Scintilla control.
  • Yes the problem occurs in the Editor++
    At one point today the cursor actually reappeared for about 5 minutes. Then it was gone

  • I dare say, then, that this is a problem we can't fix through the SRP Editor itself (apart from going with a different control for the rich editing functionality). My suggestion is to play around with various display settings in the Citrix or RDP client and see if that helps.
  • https://sourceforge.net/p/scintilla/bugs/1643/ Interesting discussion about a similar type issue that seems like what I am experiencing as it does not happen with all of my computers just the newest one. Most of the discussion is over my head but might help point to an issue for Don and Kevin.

    I am going to play with the video on my laptop and see if there is any impact. I will report back if I see anything interesting.
  • If I find something that works I will update this. I have tried most things I can think of.
Sign In or Register to comment.