Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

Embed Window

Looking at moving to OI9 and testing things work as expected, and fell at the first thing I tried.

This complex form has a Shortcut bar on the left, which I embed 4 mini screens.
On OI 8 this works fine
On OI 9 the first 2 are OK, but the 3rd just sit there and cause OI to loop.
Commenting out the 3rd causes the 4th to do the same, so I don't think it is anything to do with the form itself.

Any ideas?

Call Send_Message(@Window:".OLE_SHORTCUTS","OLE.EmbedWindow",PANE,hWnd)

Call Send_Message(@Window:".OLE_SHORTCUTS","OLE.EmbedWindow",PANE,hWnd)

Call Send_Message(@Window:".OLE_SHORTCUTS","OLE.EmbedWindow",PANE,hWnd)

Call Send_Message(@Window:".OLE_SHORTCUTS","OLE.EmbedWindow",PANE,hWnd)


  • Unfortunately, there is too much application specific code for me to recreate the crash. I can't set it up the same, nor do I have your event handling logic.

    I know it's a bit of work on your part, but short of sending me a copy of your app, would it be possible to send me an RDK the fully recreates your setup (even if it's a mimic) along with your event logic?

    Also, does the crash happen only with the Shortcut Bar or are you experiencing it with other SRP Controls as well?
  • So, this was a tough nut to crack. There is some funky interaction between the animation processes of the shortcut bar and the embedded OI forms. At first, I had some success just disabling animation, but eventually it would hang when I would collapse a group. After some searching, I found a solution to fix the problem as I was encountering it. Hopefully this fixes your issue as well. Please download SRPControls.ocx 3.2.1 RC5 and let me know if it works for you. If not, I'll have to dig deeper.
  • Colin,

    Just for my own curiosity (Kevin will have to respond to the technical issues), what happens if you use the same form in each pane?
  • Tried it and it does the same, hangs.
  • Interesting that you encounter this with a move to OI9.

    I had this problem in the past and with embedding just one form only as opposed to multiple forms. As I was only testing the functionality I didn't pursue a resolution with any great vigour.

    All I remember now was thinking that I had made it work once and then in a different app couldn't.

    It is very possible that the difference was a difference between OI8 and OI9 and I didn't make the connection at the time.

  • Kevin

    It is good that you could reproduce.
    I have installed the revised version, and this now works OK on OI 9 and also OI 8.

  • Wow Kevin, two woohoos in two days.

    ............... now what excuse can I find to play with this one?
Sign In or Register to comment.