Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

SELECT_INTO function Error

I run into an intermittent error with the SELECT_INTO function from time to time, and I'm not sure what is causing it. Thought maybe one of you gurus might have some experience with it. The debugger shows the error in SELECT_INTO_CALLBACK line 606 with the error message "Labeled common has not been defined". The debugger shows the Call Stack as follows: the program that calls SELECT_INTO, then SELECT_INTO line 1, then SELECT_INTO_CALLBACK line 606.

Any thoughts on how I can avoid these errors in the future? Is the SELECT_INTO function unstable or problematic? Should I be using other select methods?


  • I don't use Select_Into but I did quick search for you and there was a post with this exact same error. Here is the response from Bob Carten:
    Select_into_Callback uses a variable named common to store store the results of a callback.

    if method eq 'new' then call dostime(handlename)
    Equ comm_prefix$ To 'rti_seli_'
    comid = comm_prefix$:handlename
    common //comid//bufresult@, bufcolheads@, bufcolwidths@, bufRowcount@

    while the report is running, SELECT_INTO buffers the results in that common. I'm guessing that OI uses the wrong handle or that the common is freed during the report. Do you have more details about when the problem occurs?

    No further response was made so this is all there is to work with.
Sign In or Register to comment.