Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

OLE controls (.ocx/.dll) ActiveX

I am trying to install the .ocx files for use in OI, I copied SRPutil.ocx and SRPControls.ocx to my OI directory, I installed my new license (*.srplic) into the OI directory, I regsvr32 both OCX controls in the OI directory, brought up OI, went into the Editor and checked ActiveX via the Help/About, but all the controls are listed as "eval", how do I install these controls? I have two .dlls as well, SRPLicense and SRPUtilities, are these dlls still used/needed in the OI root? I also have some legacy *.ocx and *.dll (SRPShared.dll; SRPCore.ocx and actually *.ocx for each OLE control from a long time ago). After upgrades were made to the ActiveX controls, I understand all *.ocx that is needed is SRPUtil/SRPControls, is that true? Should both *.dlls be in the OI root? Time for some housekeeping in the OI root. Thx

Comments

  • You only need SRPControls.ocx and SRPUtil.ocx. All other SRP ocxs can be deleted. SRPShared.dll is also deprecated, so that can go. Since you have a new license (.srplic), you need to get rid of SRPLicense.dll. Do that, and then let's see where we're at.
  • Well, its different now, but I don't think its correct. I removed all but SRPControls/SRPUtil ocx controls, SRPUtilities.dll and *.srplic is still in the OI root. I reran regsvr32 on the *.ocx controls, restarted OI and now all registration information is MIA and all OLE controls are "eval". I have license for OLEStandard Suite and SubClass Controls, but they are listed as "eval". I will have to admit, when I originally purchase the OLE standard and subclass and datepicker controls, I tried to install but never seemed to be able to get it to work, so I had just let it ride, but would like to get this setup and start using them. Is there something else I should be looking for or doing? Thanks,
  • Ah, you are using an outdated SRP ActiveX Info program. Drop this one into your OI directory.
  • ok, did that, removed the prior *.exe in the OI root replaced with the one from above. Restarted OI, when I clicked on the "activeX" hyperlink on the dialogbox, MalwareBytes stopped the hyperlink from executing, said it was contaminated and quarantined the *.exe, so no longer resides in the OI root. So now the hyperlink does not work (display). Attached is what MalwareBytes thinks the .exe is. I have emailed the screenshot from MalwareBytes, as the option on this page to "attach file" will not let me attach the screenshot in .png format. I did earlier, but now it will not let me, this does not seem logical, but is there a limit on the size and/or number of attachments? Could not post to the forums while typing this, so logged out, close the page, refreshed the page, logged in and trying again.
  • edited August 23
    It let me this time, maybe MalwareBytes retained where I had downloaded the offending file and wanted me to close that page. I ran a Malwarebytes and McAfee scan, says the file is okay, no threats. I am going to move the download file to a couple different directories and see what happens, maybe its just confused.
  • edited August 23
    ok, started from the beginning, downloaded from your hyperlink above, to a new OS directory, ran a scan and its says its infected, so it deletes (quarantines) the file, then I can no longer posts the results on this forum, I have to logout and log back in. I must have scanned an older version of the file, as I get 100% hit rate of malware whenever I scan the file from the hyperlink above. So there is something amiss in the *.exe. Kevin do you want to scan it first, if clean maybe just email it to me??? Thanks.
  • We ran it through VirusTotal. We also have local virus protection software that checks everything we put into and pull out of dropbox.

    Malwarebytes is giving you a false positive.
  • Oh, this is coming from dropbox?? Would you mind, zipping and emailing instead? Thanks,
  • edited August 24
    Hey Kevin, in this forum there is a posting from Oct 2018 (SRP License Info) link below, in that posting you had a link for the 32 and 64 bit version of SRP_ActiveX_info.exe, I downloaded the 32 bit version from the link in that posting and it was fine, scanned by Malware, it scanned okay, installed and it seems to be working. So, I believe the link above is contaminated since I could download from a different posting and it was okay. I do not think I got a false positive. I did not realize you were using Dropbox, under contract with some clients, for security reasons, I am not allowed to use Dropbox (or many other social media) like that with development. Please let me know if something sent is via one of these community/social media sites so that I can make other arrangements. FYI - I always do a virus+malware scan, as I have virus scan run okay, but then would fail a malware check. Thanks,

    https://forum.srpcs.com/discussion/768/activex-controls-licence-info#latest
  • I cannot email it to you as gmail does not permit .exe attachments (neither zipped nor renamed). However, it occurred to me that you shouldn't be outdated on the info window in the first place, and sure enough, my installer was shipping the older version. So, if you go the SRP Editor Product Page, re-download the installer, and install the SRP Editor, you should get the 2.0 ActiveX Info window.
  • Hey Kevin, I had re-downloaded the installer last week when I mentioned anomalies (and such) occurring while using v3.0.2 of the Editor (in the SRP Editor category). At your suggestion, I re-downloaded v3.0.2, the re-download did help was some of the anomalies in the SRP editor I was experiencing, but that download did not update the SRP_ActiveX_Info.exe. So I posted my questions above in this category. I did some research in SRP's forums and in this forum category based on the URL I posted above and again below, you listed two hyperlinks for SRP_ActiveX_Info 2.0 RC1 and SRP_ActiveX_Info_64.exe in a conversation with Colin.

    I downloaded the 32bit version. I deleted the *.exe version from your link above that was infected. I copied the 32bit version from the URL you had posted for Colin (listed below) and it worked, see attached.

    I do not want to download the SRP editor again, as with all the troubles I have had since I upgraded to v3.0.2, I do not want anymore issues.

    If you click the URL below, you will see the conversation between you and Colin and two hyperlinks for the SRP_ActiveX_Info, both of those downloads passed virus/malware protection checks. Your hyperlink above is not healthy, I tried downloading from three different workstations, Win10 and Win7 and each download was infected.

    https://forum.srpcs.com/discussion/768/activex-controls-licence-info#latest

    Based on the SRP ActiveX licensing dialogbox, I believe I have it working at this point. If you would confirm based on the screenshot, I would appreciate it. Thanks.
  • edited August 25
    The screenshot above is a pre-release version of 2.0. It is not the latest version, so I cannot guarantee that it won't have issues. However, since the tool is merely informational and not critical to the operation of the controls or the SRP Editor, it should suffice for your needs.

    I'm sorry you experienced headaches upgrading to the latest SRP Editor. The fact that the SRP Editor installer needed multiple refreshes to get it right is a failing for which I take full responsibility. I will do my utmost in the future to avoid such mistakes.
  • edited August 26
    No worries Kevin, all of us have had those kind of deployments/issues/technical difficulties, if we didn't we would not be learning anything in my opinion. I have told users many times, I do not take offense to the term "bug" when they approach me with a coding issue, I look at it as an opportunity for improvement. EOM this week, will be full backups for me, so I will download v3.0.2 again and install after my EOM backups. Thank you for all your help. Regards,
Sign In or Register to comment.