Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

Printer Window not showing

When clicking on the print button SRP Editor hangs and OI needs to be removed by using "end task"
What could be wrong?


  • Charles,

    Can you confirm the version of the SRP Editor that you are using? Also, can you try to print other programs to see if they cause the lock up? I am curious if the problem is related to the size of your program or something else.

  • We can print from different other programs. We are able to print from the System Editor ++ also (it bring the standard windows screen where you can choose which printer to use)
    The version of the SRP Editor is 2.3.2 Build 09/09/2009 8:51 AM
  • Charles,

    What I meant was for you to try and print other stored procedures from within the SRP Editor, preferably a small program just to prove that it can work under certain conditions.

    Has this worked for you in the past? If so, then what has changed?

    BTW, that is a rather old version of the SRP Editor. I have no way of testing that version so all I can do is recommend that you upgrade to the latest version to see if that resolves your problem. If not, then we can work on a fix. Send me a private email if you wish to do this.

  • We have tried several SSP's with the same result. i was working in the past. It started giving issues after I started printing double sided. At first the printer would hang up and after that the hardware guys deleted and re installed my printer. That is when this issue manifested itself.
    BTW I am on a Windows 7 Professional.
  • We have tested printing from other computers (XP pro) and we have no problems what so ever.
    My computer (Win 7 Pro) does not show the print screen and hangs the OI which needs to be removed via task manager.
  • Charles,

    So how do you want to move forward? All i can report back to you is that we have not experienced this problem internally with the latest SRP Editor and we are all using Windows 7 Professional. I cannot promise that this will not be a problem for you with the latest SRP Editor but that is really the only way we can help you if the problem persists.

    I recommend that you download a copy of the SRP Editor from this site and install in a test copy of OI. Then try to print a stored procedure on your machine and let me know what happens.
  • Download did the trick. Did not know I could download without requesting permission. So now I know.
Sign In or Register to comment.