Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.



There is an error message (screenshot below), when I run this script oRec = RTI_JSON( retval, 'Parse')

What files do I miss, I have downloaded json2.js and put in OI directory,but it's not working.

Anyone knows how to solve this problem.

Thank you and Regards,

Albert K


  • I can't answer RTI_JSON questions. Is there a reason you don't want to use SRP_JSON?
  • You might need to download json2.js and place it in the HTML folder inside your OpenInsight root directory. I've run into this error message in the past and used RTI_JSON a lot prior to using SRP_JSON. There were some edge cases with RTI_JSON that were difficult to deal with when working with objects of objects or null values. Just to expand on Don's response, SRP Utilities is free and contains SRP_JSON which is well documented.
  • Funny thing is that I can't find that file in any copy of OI that I have installed. I've used RTI_JSON in the past to test things so I'm not sure how this utility worked before.
  • Very very thank you, after placing jsons2.js file to the HTML folder, that function works perfectly.

    I can't use SRP_JSON because some of our workstation computers are still using windows vista. That's why I use RTI_JSON instead of SRP_JSON because The SRP_JSON needs to instal SRP_UTILITIES v2.0, and after installing the new version of SRP Utilities, a workstation computer which is still using windows vista there will be an error like this :

  • You might be right that Windows Vista isn't supported, but that error seems more like the SRPUtilities.dll file is being blocked. Can you check the properties of the file and make sure it is unblocked?
  • It's likely because Windows Vista isn't up to date on VC++ runtimes. You can manually download and install the Universal C Runtime here.
Sign In or Register to comment.