Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

Combos and multiple monitors

This has been a bugbear of mine for some time but maybe someones got a solution if I simply ask the question.
I use the combo extensively and it works fantastic except.....

If the window is on a secondary monitor the width of the first column widens excessively which at best looks silly but at worst (when the combo is near to the edge of the screen) it looks absurd and in some instances awkward and unuseable.

Some examples:

Here's how it should look and does when it's on my primary monitor


If it's on my second monitor and it often is, the first column doesn't know how to handle its size


and if I haven't made a conscious decision to move the window way to the right of my second monitor then the combo spreads itself across both screens.


which in this screenshot doesn't look too bad but in reality if I'm looking at the screen I'm working on then all I really see is this


Comments

  • What are you setting the Width of your column to be?
  • Dynamic
  • but I just changed it to a fixed width of 100 because if that would do it, that's a workaround I could live with.

    Alas, same symptoms.
  • Ask and ye shall receive. 4.1.5 RC4 fixes this issue and improves multiple monitor support all around.
  • So I got all excited when I saw this but being that it's Easter weekend hadn't gotten near my PC to try it.

    Have now downloaded, unregistered the old and registered this version and this happens when I try and launch any of my apps.



    Stays visible for a few seconds and then closes OI. Is that likely just to be a licencing issue. I'm following that up anyway but thought it might be worth sharing that there's no actual info being displayed so I'm only guessing at the cause.
  • Yes, it's a license box that, for some reason, isn't showing the actual license screen.
  • Now I've got the licensing sorted I'm simply kicking myself I didn't ask five years ago.
    Nice job Kev, you've done it again.
Sign In or Register to comment.