Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

SRP_Controls_Install.exe

I get an error when I try and download the latest SRP controls , I am looking for 4.1.18.1 for both 32 & 64




Comments

  • Thanks for pointing that out, it looks like the link was broken for the 4.1.17 installer. I have fixed it so the download button should work again. Please be aware that 4.1.17 is the current released version and therefore the only installer version. SRP Controls version 4.1.18.1 is only available via direct download from the MDITheme post in the Subclass control category. Here is a link to that post if you need it: https://forum.srpcs.com/discussion/comment/6362#Comment_6362

    FYI, the download is only the OCX file. An installer is only made when the control is officially released. When that happens we update the installer on the SRP Product site, update the version number there, and post to the SRP Twitter and Facebook pages about the recent changes.
  • Correct, as that is all that was asked for in that thread. That is why the direct download links that are shared are very specific to the issue brought up. All other installers (32bit/64bit) and builds (64bit) have to wait for the official release. If you are also having that same issue with the 64bit version and need the installer, please post in that thread and ask Kevin for it. If you aren't having that issue, I would highly recommend that you wait a few days for the team to finish the build and make an official release.
  • Both the 32 and 64 in the install.exe have the wrong date stamped as it is showing the licences as expired.
    This was an issue that was picked up on the other thread and fix in 4.1.16.
  • 4.1.17, which is on the downloads page, fixes the datestamp issue.
  • That is where I did download it from.
    Ok I will try again assuming you just redidit.
  • Sorry, stiil the same


    I took it from here:

  • edited January 12
    Does this one work for you?
  • No, still the same (version shows as 4.1.18.2)
  • Please email me your license so I can test.
  • edited January 13
    It is not stopping the controls from working in run mode or any message in dev mode form edit
  • Please download this version of the ActiveX Info tool and see if you get the same results. A screenshot would be helpful.
  • I get different results using this exact window. The controls that expire in 2020 rightly show up as expired and the rest show up as license. This is testing against the license you sent to me.
  • Ok, must be some issue at this end, cant think what, so will just leave it for now.
    Thanks for looking into this.
  • We suspect is has to do with your localized date settings. I'll see if I can whip something up that forces all parsing to stick with ISO 8601 format.
  • I did notice that, but assumed it was covered.
    Not been an issue in the past.
    Thanks
  • Let me know if this one works any better.
  • Bingo - now a 32bit one (or will that work for OI9 as well)



  • edited January 14
    Awesome. Here's the 32-bit one. They will ship with the next release of the SRP Editor.
Sign In or Register to comment.