Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

Install Issue, maybe a path issue

I am working on setting up FrameWorks on a test machine (VM using Oracle VM VirtualBox with Windows 10 Fall Creator update). I followed the instructions on the wiki and most everything went as described in the Wiki Instructions I will explain below in the two areas that were different just in case they are pertinent. Here is a screenshot of what I am getting when launching FW_MAIN.

The RibbonControl and StatusBar are both present so I don't think it is an OCX issue. But to be safe I unregistered and re-registered both SRPControls.ocx and SRPUtil.ocx and it made no difference.

Here are the differences that I ran into.

1. On the wiki the Inventory Checklist says I should have FrameWorks_RDK.zip and FrameWorks_APPDATA.zip. I only have the one zip, and I am assuming it is all here (which could be my problem).

2. When I run the RDKInstall it asks me "Where are the application update files?"

I just hit enter here as I saw nothing in the instructions about it. I have never installed an RDK this way either so I don't know if this is normal or correct.

If I then create an entry point for FW_MAIN and launch it I get the screenshot above.

Out of curiosity, I had a look at APP_INFO*RIBBON_SETUP*FRAMEWORKS and all the icons are pointing to .\Bmps\FrameWorks. I am assuming I missed a step in the install or messed up the RDKInstall as the images never got copied into the \Bmps folder and I am guessing they are not the only thing that isn't getting copied.

Can you give me some guidance as to what I am doing wrong?


  • What OS is this running? Windows Server 2008 or Winders Server 2013 Web Server edition by default struggle within 32-bit images.
  • Kevin,
    The host computer is Windows 10 Pro 64 bit Creators update, and the VM is Windows 10 Pro 64 bit with Fall creators update.

    The host computer and the VM are not sharing any files associated with RevSoft or OI.
  • So, you are viewing FrameWorks through a remote connection of some sort. Confirm that the remote connection client is configured for 32-bit imaging.
  • Brian,

    Can you tell me how you are connecting to the VM? If it is through RDP, you are most likely not getting 32bit colors which is required by the ribbon control in order to display all of the icons and other content. I haven't tried this on a Windows 10 OS yet but you should be able to require Windows 10 to always display in 32bit colors by doing the following:

    1. Open up Local Group Policy Editor and navigate to \Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment
    2. Locate the entry called "Limit maximum color depth" and modify the setting to be "32bit".
    3. Click OK
    4. Restart the PC

    So far we have only ran into this issue on Windows Server 2008 servers so there is a chance that something else needs to be done on the Windows 10 OS to make this function. But please try the above first and we can go from there.
  • Kevin and Corby,

    VirtualBox appears to use its own connector as on the host machine there is no RDP task running. But I did go through the steps that Corby laid out to no avail. Also to test the theory that it is a 32-bit color depth issue I created a new frame and put a Ribbon on it and pointed it at some of your 32-bit png images. Low and behold I have the same issue images do not show.

    Oracle shows that it is running in 32-bit color.

    Looks like the issue has to do with Oracle VM I will see what I can track down and let you know if I come up with a solution.

    Thanks for pointing me a direction that seems to be correct. :)
  • Disregard my statement about the test Ribbon not working I had pointed them wrong the test ribbon does work with the 32-bit images.

    I put a \ at the beginning of the image address in my xml file that shouldn't have been there. I rushed the test sorry.

    So I am back to square one with having just ruled out the issue of it having anything to do with 32-bit images being the cause.
  • I rolled everything back to before I tried installing SRP FrameWork and started from the begging. This time when it asked me "Where are the application update files", I typed in the same location I did in the RDKInstall. This seems to have been what caused the issues. Now when I launch the application I get all the icons and everything seems to be working.

Sign In or Register to comment.