Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

Editor locks up creating new record

Here is a weird one that has plagued me for quite a while now. If you have a few tabs already open and [Ctrl+Shift+O] to create a new stored procedure record. You can copy/paste text in from something else and change it. However, if you do not save it BEFORE opening another record - especially an insert record, then the tab takes the title of the newly opened record. Previously it was something like "<8> Stored Procedure". If you click on the former tab, it only shows the newly opened data, so you don't know which is which. Usually, if you try to close the SRP editor and just be more careful, it will gridlock all of OI and you have to kill it from the task manager.


  • I have experienced this as well though never spent the time trying to nail down the sequence of events that caused it.
    Note to self. Always save a new record/procedure before opening anything else.
  • Guys, I can't seem to duplicate this issue. Can someone provide me with some verify specific steps to follow...hopefully using OOB routines that come with OI in either SYSPROG or EXAMPLES?
  • How do I post a video to the forum?
    1. Have the editor open with a couple of stored procedures open.
    2. Push [Ctrl+Shift+O] to open a new SP and give it a "function Crash_Example()" or whatever.
    3. Push [Ctrl+I] and open any insert record (i used one that was on my favorites list, so it comes up as the left tab).
    4. Click the upper right "X" to close the editor.
    5. When asked, save the record.
    6. OpenInsight crashes.
  • edited February 2018

    Depending on the size, the forum should allow you to upload the file here. If you click the Attach Image/File button (to the right of the link icon), you should be able to drag and drop the file into that area.

    A potentially better alternative would be to upload to a cloud storage solution like Dropbox or OneDrive and then share the public link here.
  • Jim,

    I'm guessing there is something else I need to do. I followed your steps. The one issue that did come up that was "a bug" (in my opinion) was that when I asked it to save the new stored procedure it tried to save it using the New Insert dialog. I told it to go ahead and try it, but it failed and prompted me to save it again. This time, however, it used the New Stored Procedure dialog and it worked.

    I'll play around some more to see if I can get the crash to occur.
Sign In or Register to comment.