Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

Icons not displaying when using Terminal Session Windows Server 2012 R2

I have read a number of forum feeds but I have a problem this time I am struggling to resolve.

We have a User that has just upgraded the version of our software they use and now use Ribbon Controls. A number of posts have been similar to the issue we are facing, but slightly different.

The User is using Windows Server 2012 R2. When IT run the application directly on the server the Icons are displaying and function correctly. When it is run through a terminal session via a User pc the icons do not display although if clicked where the icon should be, the correct function is performed.

My limited knowledge says to me the controls are therefore registered as they are functioning and possibly it could be related to 32 bit colour needing to be defined on the Terminal Server as opposed to 16 bit.
There were some previous posts on this issue with Windows Server 2008 R2 in a previous post.

Can anyone advise if this is similar for Server 2012 R2?
Or is there something else I am missing?

Thanks in advance for any help with this problem.


  • Just to give you a quick response, I'm most certain this is related to the same problem you've seen posted in previous threads. If someone on our team knows how to address this with Windows Server 2012 R2 they'll post an answer for you.
  • Thanks for such a quick reply Don. If I am lucky, someone might have advice on Server 2012 R2 otherwise I will start playing tomorrow.

    Thanks again for the steer.
  • Hi Troy,
    Just curious, did you get your icons to display with Windows Server 2012 (Terminal Service)?
  • Hello Ray,

    You might want to check that your terminal server is configured for 32bit color. I know this was an issue with Windows Server 2008 but I haven't tested it in 2012. Here are the steps for enabling 32bit colors in Windows Server 2008, I believe they should still work with Windows Server 2012.

    1. Open up "Edit group policy" on the server. This should open the Local Group Policy Editor.
    2. Navigate to Computer Configuration - Administrative Templates - Windows Components - Remote Desktop Services - Remote Desktop Session Host - Remote Session Environment
    3. Look for "Limit maximum color depth" in the list of settings.
    4. Choose "Enabled" and from the drop down, select 32bit.
    5. Apply the settings.
    6. Log out of session and log back in. (It might require a reboot but try a log off first)
  • Hi Corby,
    Ha, ha, thanks for the quick response. No we got it working on our 2008 Server, thanks to you. I was just wondering if Troy got it to work on Server 2012 following the same procedure.
    Thanks. Hopefully, Troy will kindly response to let me know. I'm too old to assume :-).
  • Hi Gents,
    Thanks for the advice above.
    You must be the other side of the world to me.. The day is just starting in the UK.

    Locally I got it to work on our 2008 Server following the above and have advised the client of the above procedure. The client uses Windows Server 2012 and being a larger company needs to get their IT team to handle this as it likely involves restarting the server.

    Once the change has been done I will post on here the outcome but I am hopeful that it will resolve their issue.

    Thanks again for the advice.

  • Hi Troy,
    Let's hope that it work with Windows Server 2012. It should, but again, I'm too old to assume. If it's convenient, would you mind, letting us know whether it worked or not.
    Thank you,
  • Hi Ray

    Fingers crossed..
    I will post and advise when I get a response from the user.

    Cheers Troy
  • Hi All,

    I have just received feedback from the company that had the display issues using Windows 2012. They confirmed that enabling 32 bit colour did rectify the problem.

    Thank you for your help. Very greatly appreciated and apologies for the slow response as I have only just heard from the company this morning.

    Kind Regards Troy
  • Thanks for the feedback Tony!
Sign In or Register to comment.