Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

Trouble creating new Commands on new Ribbon Manager buttons

I'm using Frameworks I made a new command in the Samples folder called INVOICE1 (see image)

I then attached this command to a button on the ribbon manager (see image)

I closed the application and re-opened it and the button does not show up. I noticed that in the Ribbon Manager it is missing the value in the dropdown for the command name. (see image) When I try to find that value in the dropdown, it is not in the list.

I can create new buttons of EXISTING commands, but not any new commands that I've tried to create. What am I missing?


  • edited May 2018
    You didn't, by any chance, delete the command using the Command Manager? I can duplicate your results by setting everything up as you described, then going to the Command Manager and deleting the "INVOICE1" command. At that point, my Ribbon Manager screen looks like yours.
  • No I didn't delete it. Right after I create the new item in the group in the Ribbon Manager it shows up with the dropdown having the value of INVOICE1. It will not show up on the actual Ribbon Control. After closing the application and re-opening it, the dropdown in the Ribbon Manager will not have the value of INVOICE1. The Command Manager will still have the command INVOICE1, but it will not populate in the Ribbon Manager dropdown. Hopefully that makes sense....
  • Here is a pic of the Ribbon Manager right after creating the new Command and the new group item.

    I closed the Ribbon Manager form and re-opened it and this is what the same new item looks like.

    Notice that the dropdown does not include the INVOICE1 command in it.

  • The machine I tried it on is running a slightly earlier version of FrameWorks (16.0.13)...I wonder if that is the difference.
  • Dan,

    I tried to replicate this in FrameWorks and I can't seem to do it. Have you tried creating another Command and seeing if this fails more than once? FYI, once you click apply, that should automatically refresh the Ribbon bar so you shouldn't need to restart the application.

    Since you aren't seeing the INVOICE1 command in the Dropdown, I believe something happen when you created the command. I would recommend that you check the FW_COMMANDS table and see if you can find the INVOICE1 record. If you do, I would then check the %RECORDS% record and see if the INVOICE1 command is listed there.
  • Corby,
    I have created several different commands all with the same result.

    I looked at the FW_COMMANDS table and found something strange going on there. I went into the SRP Editor, hit Ctrl+R to open a record, typed FW_COMMANDS for the table name and hit Refresh to see all the records in the table. The INVOICE1 command was not listed, which I thought was odd because it shows up in the Command Manager. It also was not in the %RECORDS% record.

    I used the TCL and typed "LIST FW_COMMAND" just to double check, and on the report that was printed the INVOICE1 record shows up. I also was able to find it using the Table Search tool in the SRP Editor. I'm not sure what this means. Perhaps the %RECORDS% record is not being updated as expected, and the SRP Editor uses that record to make the list of records in a table.

    I typed INVOICE1 on the %RECORDS% record and everything shows up properly. I created another command and it has the same problem. Something is not updating the %RECORDS% as expected when a new command is entered into the FW_COMMANDS table. Is this an environment problem, or code problem?
  • I had done an update with the given RDK, but I hadn't removed the old APPDATA tables and replaced with new ones. Once I attached the tables that came with the base install of the update it seems to work properly.
  • I suspect that this is due to the QuickDex not being recognized and thus is why the %RECORDS% record wasn't being updated. Whether this is because your original APPDATA tables were not properly configured for the QuickDex or perhaps that the DBT was out of sync, I'm not sure.
  • I'm having a few other problems now.

    I'm having problems with any new commands that are made in a new group. New commands that I make in an existing group function properly, but if new commands are in a group that I create it will show up in the Ribbon control but not perform the action assigned to it.

    Also, the ribbon control will not populate the changes that have been made upon initial startup. They only show up if I make a change in the Ribbon Manager and hit the Apply button.
  • Let's focus on one issue at a time. I also want to make sure we are using correct terminology to avoid ambiguity. When you refer to "new group", are you actually referring to a group in the Ribbon Manager? Also, when you say it won't perform the action assigned to it, does it do nothing or something else that is unexpected?
  • Group in the Ribbon Manager. No action at all.
  • A few more questions:
    1. Did you add this new command to a new command category?
    2. Is your command category associated with a security policy?
    3. Is this security policy enabled for your user?
    4. Did you restart FrameWorks to see if this made a difference?
  • For what it is worth, I'm not just going on a fishing expedition with these questions. I did try to reproduce your situation and the only time I experienced anything similar to what you are describing is when one or more of the above items had not been properly addressed.
  • Your questions have helped me to understand where I went wrong. Just in case anyone else runs into the same problems, here's the steps I took and what I observed:

    1. In Command Manager create new command category (CATEGORY1) and add command (COMMAND1).
    2. Open Security Policies, but cannot find the new command category (CATEGORY1) in the table. Close and re-open main form and now CATEGORY1 shows up. Under ADMIN policy, mark as enabled.
    3. Checked to make sure that ADMIN policy is enabled for user "admin"
    4. In Ribbon Manager made settings for new Tab, new Group, and new Item tied to command COMMAND1. Ribbon control showed changes on main form, but when clicked nothing happens. Re-started main form and everything works correctly.

    I didn't understand that there was a step to associate the command category with the security policy because I didn't see it as an option. Re-starting the form helps to re-populate some of those tables. Now that I know the process I think I am on my way. Thanks for the help!
Sign In or Register to comment.