Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.

Title Bar of OI Forms Load Under the Ribbon when > 100% Scaling is set in Windows

edited September 26 in SRP Ribbon Control
Hello,

When I open a form in our new MDI frame that uses the SRP Ribbon control, if scaling in windows is set to greater than 100%, then the window will have its title bar tucked underneath the bottom of the Ribbon. First, a screenshot of what I am referring to. On the left is when scaling in windows' display settings is set to 125% and on the right is when scaling windows' display settings is set to 100%. The red box is just highlighting some extra space, it was drawn on top of the screenshot.



I looked at the Ribbon Size in OI 10 post, but I'm not sure that is the same issue. If it is, I apologize.

I will continue to look at this issue, but I thought I would go ahead and make a post in case I'm missing something obvious that would save me some time in fixing this issue. I know we reposition some of our forms when they load in the MDI frame, but this has never happened until I started using scaling > 100% on a new laptop.

Thank you for any insight or help!

*Edit: OI Version: 9.4
Windows Version: 10 Pro

Comments

  • This is running on OI 9.4? Did you guys set up some kind of manifest to force OI to manually scale to the display settings? By default, OI does not support scaling in this way. In fact, I can't recreate this issue using a default copy of OI.
  • Kevin,

    That's interesting. We didn't manually set up anything like that as far as we know. It just so happens that we have recently gotten two new laptops at the office and both of them experienced this issue. The laptops are ThinkPads. I don't know if that would matter. How bizarre. When you tried to recreate it, were you in Windows 10?

    Thank you for looking into this!
  • Right click the shortcut you are using to run OI and click Properties. Check the Compatibility tab. Near the bottom is a button that reads, "Change high DPI settings". See if either of these are checked. If not, try setting the Compatibility Mode to Windows 8.
  • Thank you for the help, Kevin. In short, your suggestion worked. However, there is different behavior on each laptop. Both laptops previously had the "High DPI Scaling Override" box checked.

    On one laptop, when I checked the top box, "Use this setting to fix scaling problems..." the issue was resolved and the screen was still clear.

    On the other laptop, when I checked the top box, "Use this setting to fix scaling problems..." the issue was not resolved, and I had to also uncheck the bottom box "High DPI Scaling Override" which made the screen blurry.

    So, both laptops can now run in 125% display mode, but only one of them still works with that bottom box checked that keeps our system looking clear (text isn't blurry).

    Here is a screenshot of those two settings I referred to several times:



    Thanks again for your help and advice! If you happen to think of a reason as to why one only works with blurry text, please let me know. Thank you very much.
  • Honestly, I don't understand why they aren't both blurry. OI 9.x is not programmed to work with DPI. It should be blurry on all machines. Perhaps there is some other software that is tricking Windows into doing it non-blurry?

    If DPI support is a priority, you need to consider moving to OI X.
  • >>If DPI support is a priority, you need to consider moving to OI X
    But wont there still be a problem if DPI is enabled as Srp controls dont support it?
  • Barry, that is correct.
  • Sounds good, Kevin. I appreciate your time and suggestions! It's great to get it working, even if it is blurry on one of them. I am thankful it's not blurry on mine, haha!
Sign In or Register to comment.