Welcome to the SRP Forum! Please refer to the SRP Forum FAQ post if you have any questions regarding how the forum works.


I can't replicate this at all but every now again when using search everything dies. Editor exits memory as does OI.



  • Is this the Table Search utility or the Find utility?
  • The new find.
  • I've had this happen to me a number of times also. It hasn't happened lately, so I thought maybe it was an early bug that was fixed...
  • We'll look into this but it certainly sounds like a circumstantial bug. Please keep an eye out for the exact steps you are taking that produces the bug and report back to us.
  • I will. It happens with the search box open, and I am using the editor top edit text. It crashes when I click on the search box.
    I think that is what happens, next time it happens I'll report what I was doing.
  • We have noted this as well. I haven't posted because I was trying to identify the trigger point to replicate.

    like @jimvaughan noted, it happens when the Find dialog is displayed.
    We definately get a crash when closing the dialog. It only happens very irregularly but when it does you know because, as noted, it brings all of OI down.

    Still trying to work out the trigger but havent been able to pinpoint anything, let alone with any consistancy...
    (Did we use ESC to close or Cancel? Was the previous command a Find Next (or F3) or Find Prev (or F4)? was it just a single search or had multiple searched been executed? did we type in the the string or select text and then Ctrl-F?.....)

    I look forward to any other advancement on this! I will post more as I find anything...

  • Fixed for next release. If you want the fix right away, download SRPEditor.ocx or SRPEditor64.ocx and replace your current one. That's all you need for the crash to go away.

    To recreate the crash:
    1. Open 2 documents in the SRP Editor
    2. Do a Find on the first document
    3. Go to the second document while the Find is still open
    4. Close the second document
    5. Close the Find dialog
    6. Cry
  • Cool excellent job, thank you.
  • @KevinFournier, I tried to replicate the crash with your steps in a few of our environments I know we have experienced the crash in before I updated the OCX. Unfortunately, I couldnt force the crash even once!

    I have registered the new OCX anyway. If we experience the Find crash again I will be sure to update this thread.

    As always, thanks for the hard work and quick response!
  • Just to be clear, step 2 means doing an actual search such that you cause the search to be highlighted throughout the document.
  • Yep. :)
    My particular test found 100-odd entries and highlighted them. I even went up and down between a few results too just to replicate real life...
  • I managed to get a crash running
    I then replicated it.
    Third time for proof (and fourth for that matter ) didnt crash OI....

    Open OI. Load SRP Editor.
    Open procedure. Find something. Leave find box open.
    Open another procdure. run via Command line which triggered my debug.
    Close Debugger.
    Realise Find was in my way so close that.

    I replicated it straight away. The third time I tried without the debugger (just running a 2nd procedure) but that was fine. Now it seems find again with the debug.
    How annoying! It is getting wise to my ways and taking steps to avoid detection....
  • I am wondering if this is related to my 2nd debug crash issue as I am also using the SRP editor. My OI crash occurs when the 1st debug is aborted (debugger exit cross), then go again CRASH. If I continue the debug with F5 instead of abort then no crash for 2nd, 3rd etc. normal.
    I have updated to and still crashing.
  • @Chris_Meyer, the debug window might be a theme there! In my instance it is still the closing of the Find that triggers the crash but the debug was certainly involved in that example.
    I am still trying to find a consistent replication for Kevin to weave his magic.
    The fact I was able to reproduce easily at least once gives me some hope...
  • There's definitely more to this. I've tried this steps several dozen times and can't get a single crash. Perhaps it has to do with the search itself? Does the search term have instances in both routines? How are you closing the debugger? Are you just closing it or aborting the debug process? How are you closing the Find dialog? By pressing Cancel or hitting ESC?
  • @KevinFournier
    Im not sure of the search term (I can't remember what I was searchin to be honest) but I know I didnt process through the 2nd procedure for the search. I wasn't trying to find a string, I was only trying to trigger the debugger (it was a preset test procedure). Thats why I closed the Find, my mouse was already right there from closing the debugger...

    I habitually close the Debugger with the big red X . Just closing (no Abort).

    I habitually close the debugger with 'Cancel' although, to be honest, I do ESC it regularly enough. In this case it was definately a Cancel.

    I thought I was so close to having a pattern. Turns out not so much :(
Sign In or Register to comment.